Kaltura MediaSpace: Media is being processed error

Problem


You’ve added a video to "My Media," but it is still processing after a long time and is not able to be viewed. When you try to view it, you see a message indicating that it's still processing.

Probable Cause


It is normal for media uploaded to Kaltura to take time to process. For large, high quality videos, processing can take as long as 15 times the duration of video, although it is usually much quicker. However, sometimes an entry gets stuck processing and it is unclear to the user what is causing the issue. 

Recommended Solution


When administrators check on these stuck videos, behind the scenes we can often see the status is "uploading". When the creator tries to view the video, they only see the "Media is being processed" message. 

Unfortunately, after a significant length of time an "uploading" message means the video never fully made it to the server. It's important to have a stable internet connection. If your internet connection gets interrupted during the upload, that could lead to an issue like this. 

How did you record it?

If you used Express Capture to record your video, it may be gone. In the future, you may want to "Download a Copy" before selecting "Use This". That way you will have a copy of the video saved to your local hard drive that you can then manually upload in the event that something goes wrong.

If you used Kaltura Capture, local recordings can be found in these folders. Kaltura Capture may be the more reliable recording option if you are using a Mac or Windows PC. 

Manually re-upload

If the video doesn't upload properly, if you have saved it, you can take your local copy of the video and manually upload it. That's much less frustrating than needing to re-record an entire video, which regrettably will be what you need to do in this situation if a local copy is not available. 

If you are uncertain whether your video failed to upload, please submit a service request and our Kaltura administrators can double check the status. Please include a link to the video and/or the media title and upload date.